Funkce PRAVDA (TRUE)

Publikoval(a) Lubomír Rýgl dne

Funkce PRAVDA v Excelu vrací logickou hodnotu PRAVDA. Tato funkce není obvykle používána samostatně, ale slouží spíše jako část většího vzorce nebo podmínky.

Syntaxe funkce PRAVDA je velmi jednoduchá – stačí napsat slovo „PRAVDA“ bez uvozovek. Například:

=PRAVDA()
VB

Tento vzorec vrátí hodnotu PRAVDA.

Příklady využití funkce PRAVDA pro začátečníky mohou zahrnovat například následující:

  1. Použití jako součást podmínky: můžeme použít funkci PRAVDA v kombinaci s jinými funkcemi, jako jsou KDYŽ, A, NEBO atd. Například:
=KDYŽ(PRAVDA(), "ano", "ne")
VB

Tento vzorec vrátí řetězec „ano„, protože funkce IF zkontroluje, zda je výsledek funkce PRAVDA roven TRUE.

  1. Použití pro ověření formátování buněk: pokud chceme ověřit, zda jsou některé buňky v listu správně formátovány, můžeme použít funkci PRAVDA v kombinaci s podmínkou formátování buněk. Například:
=KDYŽ(PRAVDA(), "Buňky jsou správně formátovány", "Buňky nejsou správně formátovány")
VB

Tento vzorec vrátí řetězec „Buňky jsou správně formátovány„, protože funkce KDYŽ vždy vrátí první argument, pokud je podmínka pravdivá.

Pokročilé příklady využití funkce PRAVDA mohou zahrnovat například následující:

  1. Použití v kombinaci s funkcí INDEX a POZVYHLEDAT: pokud chceme najít hodnotu v tabulce na základě podmínky, můžeme použít funkce INDEX a POZVYHLEDATv kombinaci s funkcí PRAVDA. Například:
=INDEX(A1:A10, POZVYHLEDAT(PRAVDA(), B1:B10, 0))
VB

Tento vzorec najde první hodnotu v rozsahu A1:A10, která se shoduje s podmínkou „PRAVDA“ v rozsahu B1:B10.


0 komentářů

Napsat komentář

Avatar placeholder

Vaše e-mailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *

%d bloggers like this: