Funkce KDYŽ (IF)

Publikoval(a) Lubomír Rýgl dne

Funkce KDYŽ (anglicky IF) je jednou z nejzákladnějších funkcí v Excelu a umožňuje provést testování podmínky a vrátit hodnotu, pokud je podmínka pravdivá, a jinou hodnotu, pokud je podmínka nepravdivá. Syntaxe funkce KDYŽ je následující:

 

=KDYŽ(podmínka; hodnota_pokud_pravda; hodnota_pokud_nepravda)

 

KDYŽ funkce bere tři argumenty: podmínku, hodnotu, která se má vrátit, pokud je podmínka pravdivá, a hodnotu, která se má vrátit, pokud podmínka není pravdivá.

Pro začátečníka může být KDYŽ funkce užitečná pro zobrazování různých výsledků v závislosti na hodnotě v buňce. Například můžeme použít KDYŽ funkci k vytvoření vzorce, který vrátí „ANO“, pokud hodnota v buňce A1 je větší než 10, a „NE“, pokud hodnota v buňce A1 není větší než 10. Vzorec by vypadat následovně:

 

=KDYŽ(A1>10; "ANO"; "NE")

 

Pokročilejší použití KDYŽ funkce zahrnují kombinování podmínek a vytváření složitějších vzorců. Například můžeme použít funkci KDYŽ k testování více podmínek najednou pomocí operátoru AND nebo OR. Například následující vzorec použije KDYŽ funkci k testování, zda jsou hodnoty v buňkách A1 a B1 větší než 10:

 

=KDYŽ(AND(A1>10;B1>10);"OBA VĚTŠÍ NEŽ 10";"JEDNA NEBO OBE MENŠÍ NEŽ 10")

 

Další pokročilé použití zahrnují kombinaci KDYŽ funkce s dalšími funkcemi jako například SUM, AVERAGE nebo COUNTIF, aby se vytvořily složitější vzorce pro analýzu dat.


0 komentářů

Napsat komentář

Avatar placeholder

Vaše e-mailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *