KDYŽ

Publikoval(a) Lubomír Rýgl dne

Funkce KDYŽ v Excelu slouží k vyhodnocení logické operace IF-THEN-ELSE. Tato funkce testuje, zda je zadaný výraz pravdivý, a pokud ano, vrátí určitou hodnotu. Pokud je výraz nepravdivý, vrátí jinou hodnotu.

Syntaxe funkce KDYŽ je následující:

=KDYŽ(výraz; hodnota_pokud_pravda; hodnota_pokud_nepravda)
VB
  • výraz je výraz, který chcete testovat
  • hodnota_pokud_pravda je hodnota, kterou chcete vrátit, pokud je výraz pravdivý
  • hodnota_pokud_nepravda je hodnota, kterou chcete vrátit, pokud je výraz nepravdivý

Příklady použití funkce KDYŽ pro vyhodnocení jednoduché podmínky. Pokud chcete zobrazit text „PRAVDA“, pokud je hodnota v buňce A1 větší než 10, a jinak zobrazit text „NEPRAVDA“, použijte následující vzorec:

=KDYŽ(A1>10;"PRAVDA";"NEPRAVDA")
VB

Vyhodnocení více podmínek:

=KDYŽ(A1>90;"A";KDYŽ(A1>80;"B";"C"))
VB

0 komentářů

Napsat komentář

Avatar placeholder

Vaše e-mailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *